Getting started with ReadXplorer

This guide is intended for beginners using ReadXplorer for the first time. It will give a short
introduction about the main features of the software and how they can be used. Please be aware
that this guide is not intended to replace the complete manual.
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1. What is ReadXplorer?

ReadXplorer is a viewer and automatic analysis platform for Next-Generation Sequencing data. It can
be used to display a reference genome sequence with genomic features (annotations) alongside with
different tracks that represent read data that was mapped against the reference. In contrast to most
other viewers, ReadXplorer also offers a wide range of analysis functions that can be applied to the
visualized data.

2. When to use ReadXplorer?
The Software can be used with every data-set created by mapping read data against a reference
sequence. This can be for example a resequencing experiment or an RNA sequencing run.

3. What input data is needed?
The software has to be provided with both a reference sequence and the corresponding read
mapping data.

The reference sequence can be provided in Genbank, EMBL or Fasta format. If the Fasta format is
used corresponding genomic features (annotations) can be added in GTF/GFF2 or GFF3 format. It is
advisable to import genomic features because most analysis functions only work properly when they
are present. Nevertheless, ReadXplorer will also accept reference sequences without any annotation.

The mapped reads must be provided in sam/bam format. These files must have been created by
mapping the read data against the exact same reference as the one imported into ReadXplorer. This
is extremely important: during import the mapping files will be assigned to a reference. If the
reference noted down in the sam/bam file does not match the reference sequence it is assigned to
no reads will be visible! You are free to use the mapping tool you prefer (e.g. Bowtie, bwa, Tophat) as
long as the output is in standard conform sam/bam format!. Mapping data imported is called a track
within the software. ReadXplorer is primarily designed for Illumina short-read data (single- or paired-
end) but is not limited to it. As long as the read data can be mapped against a reference and the
output is in sam/bam format ReadXplorer can handle the data. Of course not all analysis functions
offered by ReadXplorer are sensible to use with every kind of input data. However, the software is
not designed to patronize its user unless it is inevitable and hence all analysis functions can be used
with any read mapping data-set.

L https://samtools.github.io/hts-specs/SAMv1.pdf



4. Which installer should I choose?

The ReadXplorer homepage provides various installers suitable for different setup scenarios:
Zip-x86/64-AllSystems

This is actually no installer but simply a zip file containing the ReadXplorer software which can easily
be used on all operating systems. It can be unzipped and ReadXplorer can be started by executing
one of the binaries in the “bin” directory. There are different binaries for Windows and Linux in this
directory. You must install an appropriate version of Java on your own before you can start the
program.

Exe-Windows-i386-incl Java

This is a standalone installer for Windows x86. It requires at least Windows 7. The installer comes
with its own Java version and hence no Java needs to be pre-installed on your system. Java will only
be installed for ReadXplorer. This means that if you already have a Java installation it will not be
altered. This installer comes with the 32bit version of Java. It will run on 32bit Windows systems but
you can only use a limited amount of RAM (heap-size):

The maximum theoretical heap limit for the 32-bit JVM 1is 4G. Due to various
additional constraints such as available swap, kernel address space usage, memory
fragmentation, and VM overhead, in practice the limit can be much lower. On most
modern 32-bit Windows systems the maximum heap size will range from 1.4G to 1.6G.
On 32-bit Solaris kernels the address space 1is limited to 2G. On 64-bit operating
systems running the 32-bit VM, the max heap size can be higher, approaching 4G on
many Solaris systems.?

Exe-Windows-x64-incl Java

This is a standalone installer for Windows x64. It requires at least Windows 7. The installer comes
with its own Java version and hence no Java needs to be pre-installed on your system. Java will only
be installed for ReadXplorer. This means that if you already have a Java installation it will not be
altered. This installer comes with the 64bit version of Java and hence it can only be installed on a
64bit Windows. This is the recommended way of installing ReadXplorer on a Windows computer.

Linux-i386-incl Java

This is a standalone installer for Linux. It should work on all major Linux distribution although there
are so many different distributions available that we cannot guarantee that. We test the Linux
installers on Fedora 23. The installer comes with its own Java version and hence no Java needs to be
pre-installed on your system. Java will only be installed for ReadXplorer. This means that if you
already have a Java installation it will not be altered. This installer comes with the 32bit version of
Java. It will run on 32bit Linux systems but you can only use a limited amount of RAM (heap-size):

The maximum theoretical heap 1limit for the 32-bit JVM 1is 4G. Due to various
additional constraints such as available swap, kernel address space usage, memory
fragmentation, and VM overhead, in practice the limit can be much lower. On most
modern 32-bit Windows systems the maximum heap size will range from 1.4G to 1.6G.
On 32-bit Solaris kernels the address space is limited to 2G. On 64-bit operating

2 http://www.oracle.com/technetwork/java/hotspotfaq-138619.html#gc_heap_32bit



systems running the 32-bit VM, the max heap size can be higher, approaching 4G on

many Solaris systems.2

The installer is compressed. Once downloaded open a terminal and navigate to the download folder.
Decompress the installer:

» gunzip readxplorer 2.2-1inux-1i386.sh.gz
Afterwards you can launch the extracted sh file:

» sh ./readxplorer 2.2-1inux-1386.sh
Linux-x64-incl Java

This is a standalone installer for Linux. It should work on all major Linux distribution although there
are so many different distributions available that we cannot guarantee that. We test the Linux
installers on Fedora 23. The installer comes with its own Java version and hence no Java needs to be
pre-installed on your system. Java will only be installed for ReadXplorer. This means that if you
already have a Java installation it will not be altered. This installer comes with the 64bit version of
Java and will only run on 64bit Linux systems. This is the recommended way of installing
ReadXplorer on a Linux computer.

The installer is compressed. Once downloaded open a terminal and navigate to the download folder.
Decompress the installer:

» gunzip readxplorer 2.2-linux-x64.sh.gz
Afterwards you can launch the extracted sh file:

» sh ./readxplorer 2.2-linux-x64.sh

DMG-Mac-incl Java

This is a disk image file for OS X. Like most Mac programs it does not have a real installer. The DMG is
simply opened and then the application is installed by “drag and dropping” it to the “Application”
folder. Java is included in the ReadXplorer application and hence no Java needs to be pre-installed,
an existing Java Version will not be altered. Additionally, GNU R (needed for the differential
expression analysis) is included in this installer. A GNU R instance is automatically launched when you
start ReadXplorer and automatically stopped when you close ReadXplorer. We utilize RServe listening
on port 6311 to make GNU R accessible from within Java. Please make sure that no other RServe
instance is running when you launch ReadXplorer as this might interfere with the bundled GNU R. If
you never heard of RServe, don’t worry, you will most probably be safe to launch ReadXplorer
without taking care of anything. This is the recommended way of installing ReadXplorer on OS X
computer.



5. The first run
We recommend that you start with the test data-set provided on our homepage?. This data-set
contains simulated RNA-Seq data from E.coli. Once downloaded you have to unzip it first.

When you start ReadXplorer for the first time it will look like this:
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ReadXplorer - ion and Analysis of Mapped Seq es: Quick Start

1. Open/Create a database (File -> Open/Create Database”)

2. Import a reference genome ("File -> Import data”)

3. Import a track ("File -> Import data”)

4. Explore your reference genome and tracks (via Dashboard, toolbar buttons or “Visualisation™ menu)
5. Run an analysis on your data (via toolbar buttons or *Tools™ menu)

For HELP goto Help -> Help Contents or check out the manual.

3 ftp://ftp.cebitec.uni-bielefeld.de/pub/readxplorer_repo/E.coli-simulated-Testdata.zip



Select “Open existing database”, navigate to the folder where you unzipped the test-data set and
open the database file (called “database” in this case). The view will now show you the different
references and associated tracks in the database:

ﬂi.- ReadXplorer 2.2.0 - C:\Users\Kai\Desktop\E.coli-simulated-Testdata\E.coli-simulated- Testdata'\database - O *
File Visualisation Tools Help
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Close this and open another database

Nodes Description Import Date Mark for action

= E.coli_NC_010473. L.obk E.coli_NC_010473.1.gbk 08.05.2016 O
= Track #1 simulated_normal 1.bam 06.05.2016 O
W Track #2 simulated_normal2.bam 08.05.2015 O
e Track #3 simulated_normal3.bam 06.05.2016 O
= Track #4 simulated_normal4.bam 06.05.2016 O
W Track #5 simulated_knockDown 1.bam 06.05.2016 O
- Track #6 simulated_knockDown2,.bam 06,05, 2016 O
= Track #7 simulated_knockDown3.bam 06.05.2016 O
W Track =8 simulated_knockDown4.bam 06.05.2015 O
- Track #9 simulated_upRegulated 1.bam 06,05,2016 O
W Track #10 simulated_upRegulated2.bam 08.05.2016 O
W Track #11 simulated_upRegulated3.bam 06.05.2016 O
- Track #12 simulated_upRegulated4.bam 08.05.2015 O

Export statistics of all tracks from the DB: Select all nodes
Store track statistics TR R IR A0 Deselect all nodes

A database can hold multiple references and each reference can have multiple tracks associated to it.
In this case, the database contains one reference and twelve associated tracks. Four tracks belong
together; they are simulated replicates of different conditions one might find during an RNA-Seq
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experiment. All tracks with “normal” in their name represent RNA-Seq data generated under
standard conditions (e.g. E. coli grown on normal media, at room temperature). In contrast the tracks
with “knockDown” or “upRegulated" in their name contain data one might find when generating
RNA-Seq data from non-standard conditions (e.g. different media used, heat stress etc.). In these
tracks some genes are down or up regulated in comparison to the normal data-set. You can mark the
tracks and open them using the “open selected items in new tab” button. We will mark and open one

track of each condition.



The following tab will open:
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This is ReadXplorer’s main viewing window. The different elements are described in the manual.
Aside from the visualization ReadXplorer offers various analysis tools. As a first example we will use
the “Feature Coverage Analysis” to look for uncovered coding sequences (CDS) in the data-set. All
analysis functions are configured by a wizard. You can access all analysis functions from the “Tools”
menu.



The first wizard panel asks which tracks should be included in the analysis. We select all
“knockDown” tracks and additionally check the “Combine selected tracks” checkbox. When this box
is checked, ReadXplorer will combine the read information from the selected tracks and treat them
as if they were contained in one single track.
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In the next panel the parameters for the analysis are set. As we want only uncovered CDS we check

“Detect uncovered instead of covered features”, additionally we decrease the “Min percent covered”
value to “50”.

r© -
ﬂi.' Feature Coverage Analysis Parameter Wizard Iﬁ
Steps Feature Coverage Analysis Parameters
1. Track Selection
2. Feature Coverage The first parameter defines how many percent of a
Analysis Parameters feature have to be covered with at least a coverage
3. Read Classification Selection larger or equal to the second parameter value to be
4, Feature Type Selection detected as "covered feature”,
5. Press 'Finish' to start The checkbox deddes whether only the mappings on
the strand of a feature are counted, or all mappings
within the range of the feature. I
E Min percent covered
10 Min coverage counting for the percentage

Detect uncovered instead of covered features
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In the next panel we can select which read classes should go into the analysis. Please refer to the
manual for a detailed explanation about the different read classes. We also select “Combine both
strands”. This option is useful for data-sets that are not strand specific, as in such data-sets the reads
can map to the forward or reverse strand arbitrarily regardless of their biological origin.

v |
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Steps Read Classification Selection

1. Track Selection

2. Feature Coverage Analysis 1, Select the mapping dasses to indude in the analysis (See Help -> Classification for details).
Parameters Further decide if only uniquely mapped reads should be induded, or all mapped reads.

3. Read Classification Mote that "Perfect”, "Best” and "Common” mapped reads are never unigue, thus cannot be selected
Selection together with "unigue”,

4, Feature Type Selection
5.  Press 'Finish' to start

Single Perfect Mappings [ only uniguely mapped reads
[7] Perfect Mappings 0 Minimum mapping quality
Single Best Match Mappings

[7] Best Match Mappings

|| Common Match Mappings

2. Select if mappings from the feature strand, from the opposite strand or combined from both
strands are used in the analysis.

Mapping strand selection:
() Feature strand (Default)

() Oppaosite strand
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In the next step the annotation type the analysis should be applied to must be selected. As we intend

to look at CDS we only select the “CDS” feature type. We the finished button is clicked the analysis
will start.
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While the analysis is running you can continue using ReadXplorer normally. The status of the analysis
is indicated by a progress bar in the lower right corner. You can also start additional analysis tasks
and ReadXplorer will process them in parallel.
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Once the analysis is finished a new window showing the results will open.
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If you select an entry from the results table the viewer component will automatically jump to the
start position of the associated annotation.
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As the data-set is not strand specific you can adjust the view to show all reads on the fw strand.
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This is just one simple example of an integrated analysis function. For the next example we will use
the more complex “Differential Gene Expression Analysis”, which relies on external tools that are not
a native part of ReadXplorer. They need the statistical programming language GNU R to run and you
need to set up the connection between ReadXplorer and GNU R once before you can start using the
analysis. The setup options for different operating systems are described in the manual in detail. In
general you have to visit the GNU R options panel within ReadXplorer at least once. The panel is
located under “Tools” > “Options”. On Windows we highly recommend that you just select
“Download and Install Gnu R”. This will automatically install everything that is needed to run the
“Differential Gene Expression Analysis” on a windows machine. If you already have GNU R installed:
Don’t worry, your existing installation will not be altered. For Linux operating systems and OS X you
will have to install GNU R and the needed packages on your own as described in the manual. When
you have done that go back to the GNU R options panel and set up the connection parameters that
match your installation. If you are using a local R installation most of the time it should be sufficient
to just change the radio button to “Manual”. Once the setup is complete you can start the
“Differential Gene Expression Analysis” located in the tools menu.



Once again a configuration wizard will collect the necessary information before the analysis is
started. In the first panel you have to select the tool you want to use. For this tutorial we select
“DESeq2”. Please refer to the manual for a short introduction of all the tools offered. Additionally, it
is advisable to also read the publication of the tool you want to use.

-~ —_— o = |
Ei.' Differential Gene Expression Analysis : @
Steps Choose analysis software (1. from 7)
1. Choose analysis software
.. Please choose the analysis tool you want to use for the differential gene expression analysis.
DEseqd fv




On the next panel select the tracks that should be included in the analysis. This time we select all

“normal” and all “knockDown” tracks because we want to compare these to conditions.
r T
O I 1 . 1
:-‘] Differential Gene Emiresasn Analysis Prapp— g
Steps Select tracks (2. from 6)

1. Choose analysis software

2. Select tracks Please select a reference sequence:
3. Select conditions

4, General Setup

5. Read Classification Selection

6. Start the analysis

Flease select the tracks you want to use for the analysis:

simulated_normal 1.bam
simulated_normal 2.bam
simulated_normal3.bam
simulated_normal4.bam

simulated_knockDown 1.bam
simulated_knockDown2.bam
simulated_knockDown3.bam
simulated_knockDown4.bam
simulated_upRegulated1.bam
simulated_upRegulated2.bam
simulated_upRegulated3.bam
simulated_upRegulated4.bam

< Back ][Next> ]| Finish |[ Cancel ]| Help




You must assign each selected track to a condition. Obviously, it only makes sense to assign all

I"

“norma

tracks to one condition and all “knockDown” tracks to the other.

ﬂi.- Differential Gene Expression Analysis

It |

Steps Select conditions (3. from 6)

1. Choose analysis software

2. Select tracks

3. Select conditions

4, General Setup

5. Read Classification Selection
6. Start the analysis

Tracks:

Condition one:

simulated_normal 1.bam
simulated_normal2.bam
simulated_normal3.bam
simulated_normal4.bam

Condition two:

simulated_knodDown 1.bam
simulated_knodDown2.bam
simulated_knodkDown3.bam
simulated_knodDown<4.bam

< Badk ” Next >

Finish Cancel

Help




In the next panel the annotations that should be used for the analysis run must be selected. This time
we choose “Gene”.

ﬂu Differential Gene Expression Analysis

Steps General Setup (4. from 6)

1. Choose analysis software
2. Select tracks Annotation types that should be used for the analysis:
3. Select conditions
4. General Setup
5
5]

Read Classification Selection
Start the analysis Exon

Start offset: Stop offset:

o] o]

[ save used parameters and results in an R data file for later processing

|C: \Wsers\Kai\DiffExpResult.rdata

< Back ][ Next = Finish Cancel Help




In the “Read classification” panel we change the radio button to “Combine both strands”.

ﬂu Differential Gene Expression Analysis

|'\

Steps Read Classification Selection (5. from &)
1. Choose analysis software
2. Select tracks 1. Select the mapping dasses to indude in the analysis (See Help -> Classification for details).
3. Select conditions Further decide if only uniquely mapped reads should be induded, or all mapped reads.
4. General Setup MNote that "Perfect”, "Best™ and "Commaon” mapped reads are never unique, thus cannot be selected
5. Read Classification together with "unigue”,
Selection

Start the analysis

Single Perfect Mappings [ only uniquely mapped reads
|:| Perfect Mappings 1] Minimum mapping quality
Single Best Match Mappings

[] Best Match Mappings

[] Commen Match Mappings

2. Select if mappings from the feature strand, from the opposite strand or combined from both
strands are used in the analysis,

Mapping strand selection:
(") Feature strand (Default)

() Opposite strand

(@ Combine both strands

< Back ] [ Next = Finish Help




Finally we start the analysis with a click on “Finished”.

Ei.' Differential Gene Expression Analysis

When finished, a result window will open.

Steps Start the analysis (6. from 6)

1. Choose analysis software

2. Select tracks Al necessary data has been collected.

3. Select conditions If you press “Finish”, the differential gene expression analysis will start.
4, General Setup

5. Read Classification Selection Flease note that this can take a while, espedally on large data sets.

6. Start the analysis

W

Finish ][ Cancel

ReadXplorer will now count the reads for all genes of the reference and all selected tracks and
convert them to a format DESeq2 can handle. The progress is indicated once again on the lower right

corner.



Once DESeq2 is finished a new interactive panel will open showing the results. If you click on an entry
the viewer will automatically bring you to the corresponding position. This offers an easy way to

visually inspect the results generated by the analysis tool.
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6. The ReadXplorer VirtualBox Image

Virtualization offers the ability to emulate a complete computer on top of your already running
operating system. This “virtual computer” is independent of your operating system and as long as the
virtualization software is available for your already running operating system you can execute the
“virtual computer”. This concept of virtualization makes it possible for us to prepare a “virtual
computer” with all the necessary software installed to run ReadXplorer. You only need to install the
version of the virtualization software matching your operating system and import the image of the
“virtual computer” that we offer.

As virtualization software we choose VirtualBox®. It is available for most operating systems free of
charge. Go to the download page® and download and install the version appropriate for you. Once
the installation is finished go to our homepage and download the “ReadXplorer VirtualBox image”.
Be aware that the download is quite large (~ 3.7 GB). When the download is finished, open
VirtualBox and go to “File” -> “Import Appliance...”.

[ )
l\l'j Oracle VM VirtualBox Manager =NREN X
Machine Help

&#  Preferences... Ctrl+G

g @3 snapshots
{5l Import Appliance... Ctrl+I
E
s i [E General = Preview
Virtual Media Manager... Ctrl+D Name: Read¥plorer
| @ Metwork Operations Manager... Operating System: Fedora (54-bit)

&) Check for Updates... [®] system

A\ Reset All Warnings Base Memory: 3072 MB ReadXPI orer
Processors: 2

S Exit Ctrl+Q Boot Order: Floppy, Optical, Hard Disk
Acceleration:  WT-xfAMD-V, Mested Paging, KVM Paravirtualization

OEEry
ié i (@) Powered Off
Fedora 23 32bit (sauber) _
. @ Powered Off Display

Video Memory: &4 MB
[6a]— Remote Desktop Server: Disabled
r (@) Video Capture: Disabled

Storage
Controller: IDE
IDE Secondary Master:  [Optical Drive] leer
Controller: SATA
SATA Port 0: Read¥plorer-disk 1. vmdk {Normal, 20,00 GB)
B Audio

Host Driver:  Windows DirectSound
Controller:  ICH AC37

= Network
Adapter 1@ Intel PRO/1000 MT Desktop (MAT)

(¥ usB

USE Controller:  OHCI
Device Filters: 0 (0 active)

[l Shared folders
MNone
& Description

MNone

Import an appliance into VirtualBox

4 https://www.virtualbox.org/
5> https://www.virtualbox.org/wiki/Downloads



Select the location of the downloaded image file and continue by selecting “Next”:

-

o) Imnport Virtual Appliance

E

Appliance to import

VirtualBox currently supports importing appliances saved in the Open Virtualization Format
(OVF). To continue, select the file to import below.

D:'\ReadXplorer.ova

A

Expert Mode ] [

Mext ] [ Cancel




Adjust the “CPU” and “RAM” settings if necessary. The settings below are the standard settings
chosen for a Laptop with a Quad-core CPU and 8 GB RAM. The value for RAM should be at least 2 GB

smaller than the total amount of RAM in your computer. After adjusting the setting start the import
process by selecting “Import”.

| —
Import Virtual Appliance S S
o —— - e W peel—

Appliance settings

-

These are the virtual machines contained in the appliance and the suggested settings of the
imported VirtualBox machines. You can change many of the properties shown by double-
dicking on the items and disable others using the ched: boxes below.

I Description Configuration i
Wirtual Systermn 1 A

?2' Mame Read¥plorer_1 3
@ Vendor-LIRL www,readxplorerorg
@ Version 222
= Guest 05 Type T4 Fedora (64-bit)
{2 cry 2
" RAM 3072 MB -

[7] Reinitialize the MAC address of all network cards

|Restore Defaults| | Import | | cancel |




When the import is finished a new virtual machine called “ReadXplorer” will be visible. Select the
virtual machine with one left klick and start it by selection “Start”.

|1
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The virtual machine will now boot a Fedora Linux in version 23. After booting a login screen will
appear. The default user is called “readxplorer”. There is no password set for this user so you can
login by simply selecting “Log In".

r, ReadXplorer [Running] - Oracle VM VirtualBox (SIS

localhost.localdomain @ enusutfz @ O

Suspend

Hibernate
Restart...

Shut Down...  Alt+F4

| Readxplorer

Enter your password

| Login

& » L= i [ @ B sRGRECHTS




You can launch ReadXplorer directly via the link located on the desktop.

r, ReadXplorer [Running] - Oracle VM VirtualBox

“w# Applications | = | 1419 :@m}b ReadXplorer

Trash

File System

O P L= @ @ @ B sReRECHTS

The virtual machine comes with a pre-installed GNU R installation. The E.coli test data-set is located
in the home directory of the “readxplorer” user. This means that everything is already set-up and you
can directly start using ReadXplorer and explore its functionality. If you need root access for some
reason the password is simply “rx”.

7. How can I use my own data with ReadXplorer?

ReadXplorer uses a database to maintain all important information it needs to visualize the mapping
data. In order to use your own data you must import it first into a ReadXplorer database. The data
you need is described in the section “What input data is needed?”.

To create a new database within ReadXplorer go to “File” -> “Open/Create database” and choose the
location and the name of your new DB. It usually makes sense to place the reference, the mapping
files and the database in the same folder. ReadXplorer will tell you that the database does not exist
and automatically creates a new one.



( 1;- Warning ﬁ-‘

__I; The Database ChUsers\Kai\Desktop'testh dataset\db you have chosen does not exist,
When you open, this database will be created automatically!

L

The newly created database is completely empty. To import your data go to “File” -> “Import Data”.
At first you must import your reference. While in the “Reference” tab select “Add” and choose your
reference file in any supported file format.

.} Reference Dialog [ |

Filetype: :EI'ﬂELfGenEiank file -

File: |Users\kai\Desktop\test\dataset\E.coli NC_010473. 1.abk

Mame: |E.coli_MC_010473. 1.gbk

Description:  |E.cali_MNC_010473, 1.abk

Motice:  |Note, that name of each reference sequence (e.g. each chromosome)
in the reference file has to have exactly the same name as used during
mapping of corresponding BAM files, Otherwise, the track will not show
any data!

Ok ] [ Cancel




Once you have done that switch to the “Tracks” or “Read pair Tracks” tab (depending if you want to
import single end or paired end data) and select “Add”. Navigate to your mapping files; you can
select multiple files at once. Check if the right “Reference genome” is selected.

rﬂi.- Track Dialeg : lﬁ1

Reference genome: new: E.coli_ MC_010473. 1.gbk 2016-05-11 15:16:51.587 |

Mapping type: .S.ﬁ.Mj'B.ﬁ.M Parser - |

Mapping file(s): |12 tracks to import

Description: Mote: each track gets its file name
[] was already imported in another ReadXplarer DB

Import track list: |Mapping file list: o
simulated_knockDown 1. bam
simulated_knockDown 2. bam
simulated_knockDown 3. bam
simulated_knockDown4, bam
simulated_normal 1.bam

m

Ok J I Cancel

L

Once you have entered all data you want to import you can start the import process by clicking the
“Finish” Button.

ReadXplorer will import the reference first. A Fasta file containing the sequence will be created and
indexed. Once the reference is imported ReadXplorer will start to process the mapping files one after
the other. When the input is in sam format it will be converted to bam. ReadXplorer classifies all the
reads in the file and writes the result to a new bam file which can be identified by “_extended” at the
end of the file name previous to the “.bam” file ending. A bam index file is also created for each bam
file. Once the import is finished you can start using your database.

8. How can Il increase the RAM limit?

As ReadXplorer is a Java application a RAM (heap space) limit must be specified before starting the
program. This is done in the settings file “readxplorer.conf” that is located in the “etc” directory
within the program directory. In this file you will find the parameter “-J-Xmx2G”, limiting the
maximum amount of RAM Java can allocate to 2 gigabyte (GB). You can increase this limit by
changing the “2” accordingly. You can also specify megabytes (MB) as follows: “-J-Xmx2500m”. The
default limit of 2 GB should be sufficient for most use cases. However, if you import a lot of reads
and ReadXplorer becomes unresponsive for a really long time or prints an “Out of memory”-error
you should increase the limit.



9. Iam running out of space, can I delete some of the mapping files?
ReadXplorer will keep the original sam/bam files untouched and only work on its own "extended"
copies of these files. The ReadXplorer bam files all have the word “extended” in their name (e.g.
simulated_upRegulated4_extended.bam) and are accompanied by a matching bam index file (e.g.
simulated_upRegulated4_extended.bam.bai). Note that only mapped reads are kept in the extended
mapping files. Unmapped reads are not stored to save some disk space. For the mapped reads, all
original data is present in the extended bam files plus some flags for the read mapping classification
carried out during the import into ReadXplorer. So if you do not need unmapped reads, you can
safely delete your original sam/bam files after successfully importing them into ReadXplorer without
losing any needed information. If you still want to delete the original files, but keep the unmapped
reads, you can filter them into a separate file using samtools®.

10.No read data is shown!

This is most likely a naming problem. In a sam/bam file it is noted down for each single read to which
reference it belongs. If these entry does not match the name of the reference the track was assigned
to during import, no data will be shown. All references used within the mapping file can be viewed
with samtools® by inspecting the so called “sequence dictionary”. We are facing this problem quite
often and hence there are some checks implemented during import that should warn you in most
cases if you are trying to work with non-matching entries. A common source for this error is usually
the usage of a Fasta and a GenBank file with non-matching reference names. The GenBank file is
imported into ReadXplorer but as most mapping tools need the reference in Fasta format the non-
matching Fasta file is used for this task. We have seen a lot of cases were, even if the underlying
sequence is exactly the same, the reference name in GenBank and Fasta file differ. The safest and
recommended way is to use the combination of Fasta and GFF3. Using this file type combination you
can be sure that you are working with the same reference sequence at all times. If you must use
GenBank check if the corresponding Fasta file is really exactly the same and if the names of the
reference sequence in both files are also the same. Keep in mind that not all tools handle Fasta
headers in a consistent way (it is e.g. a bad idea to have whitespaces in the Fasta header as some
tools might truncate the header at the first whitespace while others don’t). If you want to be 100 %
sure that GenBank and Fasta match there is a simple trick tough: import the GenBank file as a
reference into ReadXplorer prior to mapping your read data. ReadXplorer will create a Fasta file with
correct Fasta header during the import process. It is located in the same folder as the original
GenBank file. If you use a copy of this file for the mapping process you should not have any problem
with reference naming when importing the mapping data into ReadXplorer.

5 http://samtools.sourceforge.net/



